× Welcome to the Centrify Community! Looking for Express & Smart Card Help? Click Here

Am I missing something?

Showing results for 
Search instead for 
Do you mean 
Reply
Participant II
Posts: 4
Registered: ‎03-02-2016
#1 of 7 373

Am I missing something?

I currently am using Centrify express with DirectManage Deployment Manager installed on Server 2012 R2 linked to my Domain controller. I am trying to update the agents on my Mac computers (Currently 5.3.0-214) but I am getting a error about my OS revision.

 

Unknown OS revision 10.12.4

 

Is there a updated agent that supports this version of Mac OS? if so how do I get it?

Centrify
Posts: 3
Registered: ‎03-13-2015
#2 of 7 344

Re: Am I missing something?

Hi Alov,

 

Yes we support Mac OS 10.12 in our latest version (5.4.0).  You can find the download page from below link after filling out the form.  You can find both DirectManage (for Deployment Manager) and Agents (including Mac agent) from there.  Hope this helps and feel free to let me know if you have any question.

 

https://www.centrify.com/express/identity-service/mac-download/

 

Regards,

Alan

Participant II
Posts: 4
Registered: ‎03-02-2016
#3 of 7 330

Re: Am I missing something?

So I downloaded the latest DirectManage Deployment Manager (version 5.4.0.219) and when I go to deploy the agent it says the same things version unsupported.


Centrify
Posts: 3
Registered: ‎03-13-2015
#4 of 7 319

Re: Am I missing something?

Hi Alov,

 

Can you try to import the "centrify-product-catalog-offline" to the Deployment Manager (DM)?

 

1. On DM select the top node from left panel - "Centrify DirectManage Deployment Manager", right click and choose "Import Centrify Product Catalog..."

 

2. Click Browse and locate the centrify-product-catalog-offline.xml file:

 

<Download package>\Centrify-DirectManage-Express-5.4.0-win64\centrify-product-catalog-offline.xml

 

3. Click Next to import

 

Hope this helps.  Please let me know if you find any question.

 

Regards,

Alan

Centrify
Posts: 20
Registered: ‎09-23-2015
#5 of 7 299

Re: Am I missing something?

Hi @alov,

 

I believe the root cause is due to the current Centrify version that is installed on the Mac is 5.3.0 and it does not support OS X 10.12.x When the Deployment Manager tries to run the adcheck with 5.3.0, it will fail with the unsupported version error.

This situation will occur when end users upgrade the OS before upgrading the agent. As we always suggest customers to upgrade the the agent first before upgrade the OS to avoid this kind of incident from occuring.

Can you check if the issue only occur on Mac with 5.3.0, if they are please consider to perform a manually upgrade on the Mac to either at least versoin 5.3.3 or 5.4.0 and above directly in order for Deployment Manager to work.

Please keep us posted with the result and update. Thank you!

Best regards,
Ivan

Participant II
Posts: 4
Registered: ‎03-02-2016
#6 of 7 163

Re: Am I missing something?

How do I get the agent to do a manual install on the mac? Once that it is installed I assume I do a analyze to see if it is updated and checking in correctly?

 

Centrify Guru I
Posts: 1,719
Registered: ‎07-26-2012
#7 of 7 161

Re: Am I missing something?

https://docs.centrify.com/en/centrify/macadmin/index.html#page/macadmin%2Fadm_Installing.html%23

Want to learn more about practical Centrify examples? Check out my blog at http://centrifying.blogspot.com
Follow Centrify: