security alert with internet explorer

Showing results for 
Search instead for 
Do you mean 
Reply
Participant II
Posts: 4
Registered: ‎01-29-2018
#1 of 4 880
Accepted Solution

security alert with internet explorer

We have the SSO setup to Samanage through Centrify service. Everything is working fine, but I noticed that when we use IE, we receive the Security Alert popup message before the login. It won't show up with Chrome or FireFox. When I click the View Certificate button, it shows the name of our internal server where the Centrify Connector is running. What can we do to stop this alert message?

Centrify
Posts: 14
Registered: ‎10-31-2016
#2 of 4 855

Re: security alert with internet explorer

Hi NoahChin5,

 

Thank you for the inquiry. It seems to be related to IWA. There was a similar case as I found. The issue was resolved by disabling IWA. I am not sure what environment and setting you have but it is good to have a try if you are not using IWA.  Go to Login Policies > Centrify Portal > Other Settings > Uncheck the 'Allow IWA connections' option > Save

 

If IWA is required, please verify all setting is configured well. Please feel free to find the details as below:

https://centrify.force.com/support/Article/KB-0565-Configuring-silent-authentication-for-Internet-Ex...

 

Hope this will help. Please let me know if you have further questions. Thank you!

 

Kind Regards,

Yeny

 

Centrify
Posts: 14
Registered: ‎10-31-2016
#3 of 4 850

Re: security alert with internet explorer

Hi NoahChin5,

 

Please let me add one more thing. If you would like to use IWA and stop security alert, please ensure you have installed IWA root CA certificate. The root cert is under Settings > Network >  Centrify Connectors > choose one of your connectors> IWA Service > Download your IWA root CA certificate

 

Import IWA Certificate on the machine you wish to use Windows MFA at login do the following:
1) Open mmc
2) File -> Add/Remove snap-ins
3) Select certificates
4) Select manage certs for computer account -> Next
5) Local computer -> Finish
6) Ok
7) Open Certificates -> Trusted root certification Authorities -> Certificates
8) Action -> All Tasks -> Import
10) Next -> Browse for Certificate -> Next -> Finish
11) Wait for successfully imported message 

 

Details in below KB:

https://centrify.force.com/support/Article/KB-7934-How-to-import-IWA-root-certificate-manually-to-en...

 

Hope this will solve your problem. Please let us know if you have further questions. Thank you

 

Kind Regards,

Yeny

Participant II
Posts: 4
Registered: ‎01-29-2018
#4 of 4 821

Re: security alert with internet explorer

Thanks for the suggestions.
It didn't make a difference even after I unchecked the "Allow IWA connections" under Login Policies, Other Settings.
Although, I found this KB about IWA on the suggested KB article.
https://centrify.force.com/support/Article/KB-4257-Troubleshooting-Integrated-Windows-Authentication...

I unchecked "Enable Web Server" under Centrify Connector, IWA service, and that stopped the alert popup with IE.