Re: Please Help

Showing results for 
Search instead for 
Do you mean 
Participant II
Posts: 2
Registered: ‎05-16-2016
#1 of 5 3,544

Re: Please Help



I have done everything to remove all software from my computer in attempts to get my CAC reader to work after updating to Version 10.11.4 on my imac. I followed the instructions to the letter 3 times. I can't get the CAC reader to work SCR3310 V2.0. When I go to the diagnostics portion of the program it can’t locate the smart card. I also can’t find the card in my keychains. The light on the card reader never flashes or comes on. I can see the card reader under USB devices when it is plugged in.  It worked before updating to this OS any recomendations would be appreciated.

                               Thank you,



Centrify Advisor III
Posts: 78
Registered: ‎09-08-2015
#2 of 5 3,536

Re: Please Help

Hello @Me46673


If the reader worked prior to upgrading to 10.11.x, then you may need to update the drivers for the Reader to be compliant with the new OSX version.


Based on the model of reader you have, please look for a version which is compliant with 10.11.x


This thread describes how to rectify this issue, with a link to update drivers;


Additionally, you will need to be at the latest version of Centrify Express as well, in order to Support OSX 10.11.x


Once this is completed, and you are able to see the card reader light up when the card is connected, then you should next see the card details in the KeyChain. Because the light is not lighting when the card is connected, it generally means there is a problem with OSX and the reader itself.


I hope this helps! If not, please let us know the model of your reader as well as the version of Centrify you have installed.


Have a great day!


Ryan V

Participant II
Posts: 2
Registered: ‎05-16-2016
#3 of 5 3,532

Re: Please Help


Here is the information you requested.

Mac OS 10.11.4 (15E65)

Smart Card Reader

CR3310 v2.0 USB SC Reader:


  Product ID: 0x5116

  Vendor ID: 0x04e6  (Shuttle Technology)

  Version: 2.04

  Speed: Up to 12 Mb/sec

  Manufacturer: SCM Microsystems Inc.

  Location ID: 0xfd140000 / 4

  Current Available (mA): 1000

  Current Required (mA): 100

  Extra Operating Current (mA): 0

Centrify Version 5.2.4

The drivers are up to date. The most current operating system is being used. The most current version of Cetrify is being utilized and it still doesn't work. The Mac does see the reader under available USB devices however does not see smart cards when going to web sites or searching for them. I have uninstalled all other software and reinstalled it 3 times as per the links provided. I have restarted the computer the only thing that I did note is when trying to reinstall the certificates I get an Error code of 100001 however all the certs are still in the keychain and have not expired.


                                                                                                            Thank you,


Centrify Advisor IV
Posts: 81
Registered: ‎02-18-2015
#4 of 5 3,510

Re: Please Help

Hi Justin,


According to your description, it seems like the smart card is not being recognized by Mac. 


Could you please help to clarify the below:


1. When you insert your card into your reader - do any indicator lights flash?

There should be at least one LED on the reader to show card activity.


2. Did you see the smart card being detected into Keychain? 

Once the driver and the card reader worked properly, the Mac should recognize the card.


If the above failed, you may need to contact the card vendor for a driver and card reader that are working on 10.11.4.


Once the card can be recognized by the OS and Keychains is able to get certificates, that's when the software side (the Centrify side) comes in. Then you will need to follow the below guide to finish the setup:


Please feel free to contact us if you need any assistance.


Kind Regards,


Participant II
Posts: 2
Registered: ‎12-08-2018
#5 of 5 1,030

Re: Please Help


I have a Mac running Mojave 10.14.1 and a SCR3310v2 card reader that works fine on a PC. I have followed all the instructions on the militarycac and centrify express sites. Centrify express is installed and shows my reader, my Mac sees the reader, I deleted all other enablers and installed Centrify again, I see my CAC in the kechain app, I have all the appropriate certificates given on the military CAC site, I disabled the Mojave default card reader application, I reinstalled the drivers for the reader, and my card reader lights flash.


When I go to a CAC enabled site it does not even bring up the CAC PIN UI. It just goes to the login and password option (not CAC). Sites I have tried are: MOL, MCTIMS, and MarineNet.


Please help. I do not want to buy a PC just to have a working CAC reader. 


Thank you.