pam answering doamin in lower case

Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
CO7
Participant II
Posts: 2
Registered: ‎04-05-2018
#1 of 3 1,713
Accepted Solution

pam answering doamin in lower case

Hi Guys,

 

I joined the my centos machine to our AD using centrify. I'm able to list user groups using ID DOMAIN+user. But when I try to edit muy application pam to use pam_centrifydc.so the application complained that the pam response was only returning the user not DOMAIN+user.

Searching on google I found that I could use the auto.schema.name.format: NTLM to force it to use DOMAIN+user.

 

It did work, but for some reason now the response from pam is a lowercase domain. its returning domain+user instead of DOMAIN+user. Any idea on how to make it return the domain in uppercase?

 

Tks,

 

Roberto Cossetti

Centrify Contributor I
Posts: 14
Registered: ‎03-13-2015
#2 of 3 1,673

Re: pam answering doamin in lower case

Hello CO7,

 

Thank you for checking our Community page. 

 

Can you see if the following parameter would help, by default it's "true", please set it to false, thanks.

 

#
# Convert user name to lower case in Auto Zone. This will affect
# user home directory as well.
#
# auto.schema.name.lower: true

auto.schema.name.lower: false

 

 

Regards,

Alan

CO7
Participant II
Posts: 2
Registered: ‎04-05-2018
#3 of 3 1,568

Re: pam answering doamin in lower case

Tks alot  Alan. that worked.