How Does the Meltdown and Spectre Vulnerabilities Affect Centrify

Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Centrify Contributor I
Posts: 13
Registered: ‎08-15-2011
#1 of 1 1,163

How Does the Meltdown and Spectre Vulnerabilities Affect Centrify

[ Edited ]

Question:

What is Centrify’s stance on the Meltdown and Spectre vulnerabilities, as they relate to the hardware, operating systems, and other underlying components of your infrastructure

Answer:

Meltdown and Spectre are two recently reported security vulnerabilities with current generation microprocessors that have been reported recently; the issues are fully described in CVE-2017-5715, CVE-2017-5753 and CVE-2017-5754. This article addresses those vulnerabilities as they may relate to Centrify’s customers.
 
Application services
 
Cloud services from Centrify run on infrastructure from Microsoft (Azure) and Amazon (AWS) and could potentially pose a threat to Centrify cloud customers.
 
Amazon has reported that it has protected all instances across its infrastructure from these vulnerabilities:
https://aws.amazon.com/security/security-bulletins/AWS-2018-013/
 
and Microsoft has also released a statement for Azure:
https://azure.microsoft.com/en-us/blog/securing-azure-customers-from-cpu-vulnerability/
 
Centrify has satisfied itself that all instances used for Centrify services have been patched.

 
Infrastructure services and Centrify Connector

For our on-premise solutions and components, we recommend you work with your operating system and browser vendor to ensure patches that address these vulnerabilities are applied.